10DLC Registration Delays
Incident Report for Medallia Concierge
Resolved
This incident has been resolved.
Posted Sep 28, 2023 - 15:49 EDT
Identified
We are continuing to work with our carrier partners to address the current delays and issues with 10DLC registrations. Some Brands and Phone Numbers may continue to experience issues or delays in registering for 10DLC. Unregistered brands and phone numbers will continue to experience failures sending outbound messages.

We appreciate your patience.
Posted Sep 13, 2023 - 20:21 EDT
Investigating
We are aware of ongoing issues in the mobile carrier network where recently registered 10DLC Numbers and Campaigns are taking significantly longer to be updated.

This may lead to outbound messages being blocked for certain numbers that have already completed the 10DCL registration. Mobile Carriers are reporting delays of up to 10 days to fully register numbers.

We are actively working with our phone carrier partners to escalate these issues.
Posted Sep 08, 2023 - 12:41 EDT
This incident affected: Phone Carriers (Twilio MMS Long Code, North America, Twilio SMS Long Code, North America, Bandwidth SMS, Bandwidth MMS).